Storefront Update

  • Beiträge: 12
  • Dank erhalten: 0

Matthias antwortete auf das Thema: Storefront Update

Das Update hat geklappt.
Allerdings beobachte ich ein seltsames Verhalten:

Schaltet man die classic UI ab, also auf die neue UI, dann werde nicht alle Programmicons im Receiver angezeigt.
Einige Icons werden mit einem "X" versehen, so als wenn sie nicht gefunden werden.
Schaltet man wieder auf Classic UI um, sind die Icons wieder da.
Die Icons wurden teilweise direkt aus der betreffenden Executable genommen. Als nicht extra als ICO Datei hochgeladen.

Woran kann das liegen dass die Icons nicht richtig angezeigt werden?
So sieht das ganze dann im Receiver aus:



Loggt man sich via Webbrowser ein, fehlen andere Icons. Zusätzlich erscheint beim Anmelden dieses Fenster:


#22
Anhänge:

Bitte Anmelden um der Konversation beizutreten.

  • Beiträge: 128
  • Karma: 2
  • Dank erhalten: 5

koetzing antwortete auf das Thema: Storefront Update

IIS Rest durchgeführt? Auf aktuelles StoreFront 3.6 aktualisiert? Im SF Log geprüft? usw. einfach basics die man als Citrix Admin wissen und machen sollte.

cheers,
Thomas
#23

Bitte Anmelden um der Konversation beizutreten.

  • Beiträge: 12
  • Dank erhalten: 0

Matthias antwortete auf das Thema: Storefront Update

koetzing schrieb: IIS Rest durchgeführt? Auf aktuelles StoreFront 3.6 aktualisiert? Im SF Log geprüft? usw. einfach basics die man als Citrix Admin wissen und machen sollte.


IIS Reset: Ja
Aktuelles Storefront: Wir sind auf der LTSR Version
SF Log: Ja, steht nichts relevantes drin :-(
#24

Bitte Anmelden um der Konversation beizutreten.

  • Beiträge: 128
  • Karma: 2
  • Dank erhalten: 5

koetzing antwortete auf das Thema: Storefront Update

Wenn es einen Fehler im Frontend gibt dann wird das auch ins log geschrieben...

cheers,
Thomas
#25

Bitte Anmelden um der Konversation beizutreten.

  • Beiträge: 12
  • Dank erhalten: 0

Matthias antwortete auf das Thema: Storefront Update

Oh, da ist mir doch was durch die lappen gegangen. Folgendes Event wird geloggt:

Ein Fehler ist aufgetreten bei der Authentifizierung.
System.NullReferenceException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
AuthenticationControllerRequestUrl: https://STOREURL
bei Citrix.Web.AuthControllers.Controllers.AuthBaseController.EnumerateProtocolChoices(CitrixAuthChallenge challenge)
bei Citrix.Web.AuthControllers.Controllers.FederatedAuthBaseController.Login(IClaimsPrincipal claimsPrincipal)


sowie

Ein Fehler ist aufgetreten beim Auflisten der vom Receiver StoreFront-Authentifizierungsserver unterstützten Authentifizierungsprotokolle mit der angegebenen Aufforderung.
System.NullReferenceException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
bei Citrix.Web.AuthControllers.Controllers.AuthBaseController.EnumerateProtocolChoices(CitrixAuthChallenge challenge)


Quelle: Citrix Receiver for Web ID 3 und 6

Der Fehler wird aber nur beim erstmaligen Start/Anmelden des Receivers geloggt. Deshalb habe ich ihn erst nicht gesehen. Ist aber reproduzierbar.
#26

Bitte Anmelden um der Konversation beizutreten.